Welcome Guest! Log in or Register.

Ubuntu 10.04 Installation – Gateway GT5432

Gateway GT5432
AMD Athlon 64 X2 5000+
NVIDIA GEForce 6150SE (not in use)
Dual Acer x223w Monitors on Dual Head ATI Radeon HD 2600 XT
WMP54G Wireless Mini-PCI Card


Installed Ubuntu 10.04 Lucid Lynx. Created 2gb swap partition, 12gb root partition, and the rest went /home.


All network devices worked fine right out of the box. Manually setup a connection to my wireless (I prefer a static IP) using Network Manager applet. Selected “Available to all users” to avoid keyring dialogs. Connected.


I ran:

$ sudo apt-get update
$ sudo apt-get upgrade

Restart required.


Audio worked out of the box too.


Video worked out of the box, but I went ahead and installed the proprietary drivers from ATI.
$ mkdir ~/driver
$ sudo sh --extract ~/driver
$ cd ~/driver/
$ sudo ./ -- --buildpkg Ubuntu/karmic
$ cd ~/
$ sudo apt-get install dkms
$ sudo dpkg -i *.deb
$ sudo aticonfig --initial=dual-head --screen-layout=right --overlay-on=1


$ sudo amdcccle

I then changed to “Multi-display desktop (with display 2)” in CCC and restarted again.

$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 2600 XT
OpenGL version string: 3.3.10834 Compatibility Profile Context


Installed the following software with no problems:
$ sudo wget --output-document=/etc/apt/sources.list.d/medibuntu.list$(lsb_release -cs).list && sudo apt-get --quiet update && sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring && sudo apt-get --quiet update
$ sudo apt-get install libdvdcss2
$ sudo apt-get install ubuntu-restricted-extras
$ sudo apt-get install gnome-do
$ sudo apt-get install xchat-gnome
$ sudo apt-get install filezilla
$ sudo apt-get install openssh-server
$ sudo add-apt-repository ppa:stebbins/handbrake-releases && sudo apt-get update && sudo apt-get install handbrake-gtk
$ sudo add-apt-repository ppa:mozillateam/firefox-stable && sudo apt-get update && sudo apt-get install firefox ubufox


I’m a web developer and designer, so I gotta have my LAMP stack.
$ sudo apt-get install apache2
$ sudo apt-get install php5 libapache2-mod-php5
$ sudo apt-get install mysql-server

My www projects directory is located on an external NTFS drive. So, I had to make some changes in fstab to load my external drive with the correct permissions.
$ sudo umount /media/FreeAgent\ Drive/
$ sudo mkdir /media/FreeAgent\ Drive/
$ sudo blkid
/dev/sdf1: UUID="7ED05D74D05D341D" LABEL="FreeAgent Drive" TYPE="ntfs"
$ gksudo gedit /etc/fstab

Added to /etc/fstab
# Adds external drive with read/write permissions (\040 escapes space)
UUID=2020202020202020 /media/FreeAgent\040Drive ntfs defaults 0 0

$ sudo mount -a
$ sudo rm -R /var/www
$ sudo ln -s /media/FreeAgent\ Drive/Projects/www /var
$ sudo apache2ctl -k restart

This entry was posted on Wednesday, June 22nd, 2011 at 6:49 pm and is filed under Linux, Ubuntu. You can follow any responses to this entry through the RSS 2.0 feed. You can leave a response, or trackback from your own site.

Leave a Reply